fbpx
2 Town Press Media

Can’t edit Ninja form after the update to WP 5.6? Here is the fix.

Our development team is aware of an issue with an Elementor JS error occurring from scripts loaded within the Ninja Forms builder on WordPress version 5.6.

Elementor is loading scripts in our builder that should not be loaded. These scripts depend on outdated JavaScript that’s not present in our builder anymore as we’ve replaced those to remain compatible with newer versions of WordPress.

We apologize for the conflict.  I heard that the issue was forwarded internally to the Elementor devs.  I hope that the Elementor engineers and our developers are able to resolve this soon.

To alleviate the issue short-term, if you would, can you temporarily roll WordPress back to version 5.5.3 and let us know if this works for you?

Alternatively, from feedback from a different client, they were able to temporarily resolve the issue and edit their forms by installing the “Enable jQuery Migrate Helper”: https://wordpress.org/plugins/enable-jquery-migrate-helper/

After installing this, they navigated to Tools > jQuery Migrate and set the jQuery version to “Legacy 1.12.4-wp”.

I tested this on one of my websites and I was able to edit my Ninja Forms even with Elementor enabled.

Please give this a try and let us know if this works for you.

Once we get word of a path forward or fix from our engineers, we will send a follow-up email.

If you have any questions or comments, please let us know and we’llll be more than glad to assist you.